Forum TSC

Forum de partage de jeux Zelda amateurs


Vous n'êtes pas connecté. Connectez-vous ou enregistrez-vous

Problèmes, bugs et défauts du moteur

Aller à la page : 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas  Message [Page 1 sur 2]

Wendy

avatar
Admin
Admin
Ici, vous pouvez montrer un bug ou un problème que vous pensez avoir décelé dans le moteur.
Merci d'expliquer clairement les soucis (des captures d'écran sont utiles).


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

Papy39

avatar
Maker
Maker
Je viens seulement de commencer TTC (eh, oui, un Papy a parfois beaucoup d’occupations, et demain ce sera pareil !), donc un peu tôt pour se forger une opinion, mais impression très favorable pour un début de jeu.

Mais venons-en au BUG.

J’ai acheté un pain, trouvé une épée, occis des corbeaux en allant voir la grotte au sud du village (ces sales bêtes m’ont surpris et j’ai perdu un cœur mais je l’ai récupéré, j’ai regardé mon statut (mises en pause), etc… Puis j’ai sauvegardé le tout sur le fichier 1 (Partie_1.dat)

Comme j’avais oublié de noter la couleur des yeux du pauvre chaton kidnappé (c’est peut-être un  indice important), j’ai recommencé une partie sur la Partie n°2 jusqu’à me trouver dans ma maison, dont je ne suis pas sorti.
Et là, j’ai lu les STATS : celles-ci ne devraient mentionner que les quelques pas faits dans ma maison :

Et voici le BUG : les STATS de la partie 1 s’affichent, avec des coups d’épée donnés (je n’ai pas d’épée), des rubis dépensés (je n’ai pas de bourse), etc…
Je fais « entrée » pour mettre en pause : mes stats affichent une mise en pause supplémentaire.
Je sauvegarde sur le fichier Partie_2.dat et je ferme le jeu.

En retournant dans ma maison avec successivement les 2 parties, j’ai les mêmes STATS avec une seule différence : une mise en pause supplémentaires sur la partie 2.

Pour terminer, je reprends la Partie 1 et j’ouvre et referme 3 fois l’écran pause et je sauvegarde sur Partie_1.dat : ces 3 mises en pause n’affectent pas la sauvegarde Partie_2.

J’ai fait des tests similaires sur la Partie_3.

Conclusion : ce BUG affecte les sauvegardes 2 et 3 (qui enregistrent les STATS de la Partie_1), mais seulement avant qu’on les utilise pour jouer.

Voilà un petit travail pour Wendy : bon courage !   Razz 

Je reprendrai le jeu demain soir (je n'ai pas avancé beaucoup aujourd'hui avec ce Bug à cerner).   Smile


_________________

Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
L'erreur est d'une bêtise monstrueuse...

Pour faire simple : lorsqu'on charge un profil, les données sont chargées en mémoire (statistiques, inventaire, ...). Mais : ces données ne sont pas détruites de la mémoire si on quitte le profil. Si c'est une nouvelle partie, toutes les données sont effacées pour partir de rien.
Et là est la solution du problème que tu as évoqué : si une nouvelle partie est commencée, les statistiques n'étaient pas réinitialisées !

Du coup, en chargeant le 1er profil, la mémoire va acquérir des statistiques. Et lorsqu'un 2nd profil sera créé, les mêmes données des statistiques seront utilisées (charger un profil existant ne cause pas ce problème).
Et pire : dans la mémoire, il peut y avoir des valeurs quelconques là où les statistiques seront rangées...

L'erreur a été corrigée dans le lien (précision : les sauvegardes sont évidemment utilisables entre les versions).

Merci Papy39 pour ce rapport =^.^=


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

templier37

avatar
Membre de bronze
Membre de bronze
J'avoue ne pas bien comprendre les posts cités plus haut, tout ce que je peux dire que c'est que j'ai copié ma sauvegarde de mon fichier 1 sur le fichier 2 pour que mon fils puisse en profiter et je n'ai pas eu de soucis. Il a repris au meme endroit que moi. Mais je n'y entend rien en informatique, je ne peux que constater une trés grande différence en graphisme et jouabilité avec ce nouveau moteur.


_________________
<br>
Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
Le problème est simple : imagine un pot dans lequel tu viens mettre les données statistiques.
Au chargement du jeu, ce pot est vide.
Lorsque tu charges un profil, le pot se remplit.
Si tu quittes le profil en question pour en charger un autre (déjà existant), le pot est rempli des nouvelles données (les anciennes écrasées).
Et le pépin : le pot n'est pas vidé si une nouvelle partie est commencée : les données précédemment utilisées sont toujours en usage.


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

templier37

avatar
Membre de bronze
Membre de bronze
Wendy a écrit:Le problème est simple : imagine un pot dans lequel tu viens mettre les données statistiques.
Au chargement du jeu, ce pot est vide.
Lorsque tu charges un profil, le pot se remplit.
Si tu quittes le profil en question pour en charger un autre (déjà existant), le pot est rempli des nouvelles données (les anciennes écrasées).
Et le pépin : le pot n'est pas vidé si une nouvelle partie est commencée : les données précédemment utilisées sont toujours en usage.

Ah, je comprend mieux maintenant, ceci enrichit une de mes lacunes. Merci.


_________________
<br>
Voir le profil de l'utilisateur

Angenoir37

avatar
Membre d'or
Membre d'or
J'ai eu un souci avec la sauvegarde qui ne semble pas fonctionner correctement.dans les donjons

J'ai sauvegardé plusieurs fois avec le bouton échap et également lorsque je suis mort.Là j'étais arrivé pour affronter le boss du donjon 1 j'ai plusieurs fois sélectionné sauvegarder et continuer après une défaite.Or lorsque j'ai constaté après une mort que mon nombre de flèches était trop bas j'ai sélectionné quitter sans sauvegarder..

Et là mauvaise surprise je me retrouve qu'avec trois cœurs au lieu des quatre que j'avais.Plus de rubis et tout à refaire depuis un moment ou j'étais mort en extérieur.


_________________
Testeur officiel et conseiller musical du projet "LE CHAUDRON D'OR" de Papy39.
Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
Sur ce bug par contre, je suis désarmée. Le système de sauvegarde a été testé (même en cas de mort), et tout semble fonctionner.
Peut-être que ta version de Windows pose des problèmes de compatibilité...

Vraiment bizarre comme bug ! Tu l'as eu juste une fois ou il se réitère ?


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

Angenoir37

avatar
Membre d'or
Membre d'or
Toutes mes excuses pour t'avoir inquiétée Wendy en fait j'ai trouvé le problème.

Lorsque j'ai tenté de sauvegarder dans le donjon au lieu d’appuyer sur espace j’appuyais sur entrée pensant bien faire (vu que c'est couramment la touche de validation) du coup ma sauvegarde n'était pas prise en compte.

J'ai donc recommencé et terminé le jeu à l'heure où je te parle par contre je n'arrive pas à faire un 100 % mais je vais t’expliquer tout cela par MP.

Encore désolé pour cette fausse alerte.


_________________
Testeur officiel et conseiller musical du projet "LE CHAUDRON D'OR" de Papy39.
Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
Pas de souci =^.^=
Tout le monde fait des erreurs !


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

Papy39

avatar
Maker
Maker
Quelques anomalies (pas bien graves).

Carte donjon 2 :
-Elle est intitulée  « 3 – Château d’Hyrule » au lieu de « 2 – Château d’Hyrule »
-Elle montre une porte au RDC entre B1 et C1 : cette porte n’existe pas.

Grappin :
Il permet de ramasser à distance les butins donnés par les ennemis (tués avec le grappin ou une autre arme).
Le boomerang n’aurait donc aucune utilité ?
La différence est que le grappin amène ces objets au pied de Link, le boomerang les intègre directement dans le statut de Link.


_________________

Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
Le nom du château d'Hyrule dans la carte : très bête erreur de frappe.
La carte de ce donjon : aussi une bête erreur de placer une porte là où il n'y en a pas.
L'erreur est humaine dit-on... Merci de ces rapports !

Le boomerang et le grappin ont plusieurs différences :
- la portée : le grappin va plus loin que le boomerang,
- la puissance : le grappin est plus puissant,
- la maniabilité : le grappin ne va qu'en ligne droite, et Link est bloqué tant qu'il l'utilise ; le boomerang revient vers Link au retour, et Link peut se déplacer librement pour promener le boomerang. Ce qui, dans une certaine situation, fera la différence...


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

Papy39

avatar
Maker
Maker
J'étais tranquillement en train de me faire tuer (pour la soixantième fois environ) par le Boss du Temple du lac (lui n'avait pas encore perdu la moindre parcelle de vie), quand je me suis soudain retrouvé sur cet écran, immobilisé sans pouvoir bouger :



Un coup d'épée m'a débloqué, une flèche (droite ou gauche) m'envoyait à l'autre bout de l'écran, et soudain je me suis retrouvé dans une salle proche de celle du boss, puis un écran tout noir, et retour au bureau Windows d'où j'ai pu relancer le jeu, à priori sans dégât.

Je ne sais pas si tu pourras trouver la cause de cet incident, je le signale à tout hasard.


_________________

Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
C'est quoi ce bug !? Le système de collision ne permet pas d'arriver sur le plafond d'un donjon...

Dans l'immédiat, je ne peux rien faire. Essaie de donner le maximum de détails sur le combat : juste avant de te retrouver sur le plafond :
- ton pourcentage approximatif,
- si tu étais loin du boss ou s'il te collait et très près,
- si tu as été touché par le boss ou sa munition,
- si tu étais près des murs ou loin (encore mieux : de quel mur),
- et éventuellement le plus de détails que possible.


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

Papy39

avatar
Maker
Maker
Je suis malheureusement incapable d'en dire davantage.

J'ai tellement de difficultés avec mes vieux doigts, lents et difficiles à synchroniser, que maintenant devant les boss et miniboss je suis tendu et incapable de voir tout ce qui se passe, il y a trop de choses et c'est trop rapide (en particulier je ne vois jamais les pourcentages, ni mes coeurs, seulement la barre de vie du boss car elle est au centre de l'écran).

Le temple du lac Hylia aurait un plafond ? J'ai eu le réflexe de prendre cette image car l'écran était bloqué sur ce fond bleu, c'est tout ce dont je me souviens.

Désolé de ne pouvoir faire plus !


_________________

Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
Ce plafond est le carreau utilisé pour les salles n'existant pas.
Tous les étages d'un même donjon ont la même surface qui est rectangulaire. Pour faire une forme de goutte d'eau, il faut évidemment "détruire" des salles : et ce sont elles qui ont ce plafond.

Pour ton bug Papy39, on attend un autre membre, peut-être qu'il retombera. Dans l'actuel, je ne peux rien faire.

Pour les buissons, j'ai modifié le code permettant de voir si l'épée a atteint le buisson. Les résultats étant encourageants, je vais étendre ceci demain aux ennemis.


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

VL437


Nouveau
Nouveau
Petite impasse. Dans la plaine est, il y a un pont qui passe par dessus ne rivière et une clôture de bois parallèle à la rivière. Si on utilise le grappin sur la clôture depuis l'autre rive, Link sera coincé.

C'est mineur, il suffit de sauvegarder et quitter pour s'en sortir.

J'ai l'impression que les deux petits arbres sont supposé nous empêcher d'arriver là, mais on peut très bien passer entre les 2 en marchant en diagonale.

Spoiler:

Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
Les arbres ont été placés pour éviter ce problème. Mais il se règle assez vite.

Merci d'avoir signalé !


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

templier37

avatar
Membre de bronze
Membre de bronze
Bonjour à tous, je voudrais exposer un souci, mais mineur: j'ai terminé le jeu pour la 2em fois mais j'ai constaté que la première fois que j'ai affronté le boss final, j'ai anéanti le trinex avant de tuer Ganon. Ok mais cette fois ci j'ai tué le trinex et suis arrivé directement devant le chat prisonnier, sans affronter Ganon. Est ce là, un bug ou ai je accompli un exploit en tuant le trinex plus vite. Merci .


_________________
<br>
Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
Il y a un problème, et je pense en avoir trouvé la cause...

As-tu d'abord chargé la partie terminée (Ganon mort) puis créé une nouvelle partie (sans avoir quitté le jeu entre temps) ? Si tel est le cas, je connais la source du problème (qui est un bête oubli de ma part).


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

templier37

avatar
Membre de bronze
Membre de bronze
Pas du tout, j'avais termine et desinstalle le jeu pour le reprendre depuis quelques jours depuis le début, sans utilisé de sauvegarde antérieure.


_________________
<br>
Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
Donc ce n'est pas ce à quoi je pensais...
Merci d'avoir signalé le problème, même si dans l'immédiat, je ne peux rein faire.


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

templier37

avatar
Membre de bronze
Membre de bronze
Oh ce n'est pas un souci tu sais, c'est juste pour savoir.


_________________
<br>
Voir le profil de l'utilisateur

Benoit

avatar
Modérateur
Modérateur
Et un nouveau bug. Ca m'est arrivé en sortant de la mine à l'est du village de base (si l'on peut dire...)
Ca peut être corrigé en retournant dans la mine et en ressortant.

Voir le profil de l'utilisateur

Wendy

avatar
Admin
Admin
Ca t'arrive souvent comme bug ?
Je ne sais pas comment il a pu arriver. Lorsque l'écran est complètement noir, le tileset bascule...


_________________
Ne craignez rien, forumeuses et forumeurs : Helmasaur veille au grain..
Voir le profil de l'utilisateur http://tloztsc.1fr1.net/index.forum

Contenu sponsorisé


Voir le sujet précédent Voir le sujet suivant Revenir en haut  Message [Page 1 sur 2]

Aller à la page : 1, 2  Suivant

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum